Page Menu
Home
c4science
Search
Configure Global Search
Log In
Files
F96609639
liboncilla0.3-dev.postinst
No One
Temporary
Actions
Download File
Edit File
Delete File
View Transforms
Subscribe
Mute Notifications
Award Token
Subscribers
None
File Metadata
Details
File Info
Storage
Attached
Created
Sat, Dec 28, 21:12
Size
479 B
Mime Type
text/x-shellscript
Expires
Mon, Dec 30, 21:12 (1 d, 23 h)
Engine
blob
Format
Raw Data
Handle
23215396
Attached To
R6622 liboncilla
liboncilla0.3-dev.postinst
View Options
#!/bin/sh
set -e
#just generate all the file we diverted from
if [ ! -L /usr/lib/librci.so ]
then
ln -s /usr/lib/librci.so.0.4 /usr/lib/librci.so
fi
pkg=liboncilla-dev
removed_diversion="/usr/lib/librsc.so /usr/lib/pkgconfig/rsc0.9.pc"
for d in $removed_diversion
do
if dpkg-divert --package "$pkg" --list | grep -F "$d.diverted-$pkg"
then
dpkg-divert --package "$pkg" --remove --rename \
--divert "$d.diverted-$pkg" $d
fi
done
#DEBHELPER#
exit 0
Event Timeline
Log In to Comment