Homec4science

Rename PMAP_CONTRIB_MAXBINS to PMAP_CONTIRB_MAXCOEFFS in pmapcontrib.h, since…

Authored by U No Hoo <roland.schregle@gmail.com> on Fri, Jan 14, 04:45.

Description

Rename PMAP_CONTRIB_MAXBINS to PMAP_CONTIRB_MAXCOEFFS in pmapcontrib.h, since there's no more 1:1 correspondence between bins and wavelet coeffs in the padded wavelet xform. Added check for an mRGBE data field (coefficient index) overflow if too many bins are specified. This ensures early bailout before actually distributing and building the contribution photon map. Fixed mRGBE data overflow error msg format.

Details

Committed
U No Hoo <roland.schregle@gmail.com>Fri, Jan 14, 04:45
Pushed
GTFri, Jan 14, 05:15
Parents
R10977:00d0b6d23aa4: Revised symmetric/reflected wavelet xform boundary extension to repeat…
Branches
Unknown
Tags
Unknown